SharePoint Errors

  • The Web application at “[URL]” could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.
    (or)
    Retrieving the COM class factory for component with CLSID {BDEADF26-C265-11D0-BCED-00A0C90AB50F} failed due to the following error: 80040154.
    Solution:
    Change the debugging platform from X86 to Any CPU or X64 to Any CPU.
  • One or more field types are not installed properly. Go to the list settings page to delete these fields.
    Solution:
    Check the internal name of the field and use the same name for CAML query.
  • Error occurred in deployment step ‘Activate Features’: 0x80070002
    Solution:
    In my case, this was caused by an invalid ‘ListURL’ setting in my elements.xml file.Be sure the ‘Site URL’ property of your project points to the site that the List resides.If this is pointed to the level above, the list will not be found, and you will get the error above.
    ListURL needs to be ‘Lists/'{your list name} ex. List/Customers, thus you see why it is important for the Site URL to be set properly.
  • Failed to create receiver object from assembly “DLL Name, Version=1.0.0.0, Culture=neutral, PublicKeyToken=03bbc5f953b94a2b”, class “xxxxxxxxxxx.EventReceiver” for feature “FeatureName” (ID: 74C81B9A-D987-4bd1-9438-34E05D8C62BF).:  System.ArgumentNullException: Value cannot be null. Parameter name: type     at System.Activator.CreateInstance (Type type, Boolean nonPublic)    at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject () ServerX: Failed to create receiver object from assembly “DLL Name, Version=1.0.0.0, Culture=neutral, PublicKeyToken=03bbc5f953b94a2b”, class “xxxxxxxxxxx.EventReceiver” for feature “FeatureName” (ID: 74C81B9A-D987-4bd1-9438-34E05D8C62BF).: System.ArgumentNullException: Value cannot be null. Parameter name: type     at System.Activator.CreateInstance (Type type, Boolean nonPublic)    at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject ().
    Solution:
    The SharePoint 2010 Timer service cached the old DLL. To fix the issue restart the SharePoint 2010 Timer Service.
  • SharePoint Modal Dialog issue with anchor tag with image button
    Solution:
    Remove the “href: attribute” for anchor tag in SharePoint Modal Dialog.
Advertisements